source: trunk/debathena/config/reactivate/debian/rules @ 24080

Revision 24080, 550 bytes checked in by broder, 15 years ago (diff)
In cluster-login-config: * Deny everybody sudo privileges by default, then override that for the admin group. This makes sure that everybody is somewhere in the sudoers file, which also ensures that they get lectured. In reactivate: * Specify both of the lecture files in /etc/sudoers: error for everybody, and warning for the admin group. The latter overrides the former.
  • Property svn:executable set to *
Line 
1#!/usr/bin/make -f
2
3DEB_DIVERT_EXTENSION = .debathena
4DEB_DIVERT_FILES_debathena-reactivate += \
5        /etc/gdm/Xsession.debathena
6DEB_TRANSFORM_FILES_debathena-reactivate += \
7        /etc/pam.d/su.debathena
8DEB_REMOVE_FILES_debathena-reactivate += \
9        /etc/xdg/autostart/jockey-gtk.desktop \
10        /etc/xdg/autostart/update-notifier.desktop
11
12DEB_UNDIVERT_FILES_debathena-reactivate += \
13        /etc/pam.d/sudo.debathena
14DEB_UNDIVERT_VERSION_/etc/pam.d/sudo.debathena = 1.25.2
15
16include /usr/share/cdbs/1/rules/debhelper.mk
17include /usr/share/cdbs/1/rules/config-package.mk
Note: See TracBrowser for help on using the repository browser.