source: trunk/third/libxslt/libxslt.spec @ 18543

Revision 18543, 4.0 KB checked in by ghudson, 21 years ago (diff)
This commit was generated by cvs2svn to compensate for changes in r18542, which included commits to RCS files with non-trunk default branches.
Line 
1Summary: Library providing the Gnome XSLT engine
2Name: libxslt
3Version: 1.0.24
4Release: 1
5License: MIT
6Group: Development/Libraries
7Source: ftp://xmlsoft.org/XSLT/libxslt-%{version}.tar.gz
8BuildRoot: %{_tmppath}/%{name}-%{version}-root
9URL: http://xmlsoft.org/XSLT/
10Requires: libxml2 >= 2.4.23
11BuildRequires: libxml2-devel >= 2.4.23
12BuildRequires: python python-devel
13BuildRequires: libxml2-python
14Prefix: %{_prefix}
15Docdir: %{_docdir}
16
17%description
18This C library allows to transform XML files into other XML files
19(or HTML, text, ...) using the standard XSLT stylesheet transformation
20mechanism. To use it you need to have a version of libxml2 >= 2.3.8
21installed. The xsltproc command is a command line interface to the XSLT engine
22
23%package devel
24Summary: Libraries, includes, etc. to embed the Gnome XSLT engine
25Group: Development/Libraries
26Requires: libxslt = %{version}
27Requires: libxml2-devel >= 2.4.23
28
29%description devel
30This C library allows to transform XML files into other XML files
31(or HTML, text, ...) using the standard XSLT stylesheet transformation
32mechanism. To use it you need to have a version of libxml2 >= 2.3.8
33installed.
34
35%package python
36Summary: Python bindings for the libxslt library
37Group: Development/Libraries
38Requires: libxslt = %{version}
39Requires: libxml2 >= 2.4.23
40Requires: python
41
42%description python
43The libxslt-python package contains a module that permits applications
44written in the Python programming language to use the interface
45supplied by the libxslt library to apply XSLT transformations.
46
47This library allows to parse sytlesheets, uses the libxml2-python
48to load and save XML and HTML files. Direct access to XPath and
49the XSLT transformation context are possible to extend the XSLT language
50with XPath functions written in Python.
51
52%prep
53%setup -q
54
55%build
56%configure
57make
58
59%install
60rm -fr %{buildroot}
61
62%makeinstall
63
64#
65# this is a bit ugly but tries to generate the bindings for all versions
66# of python installed
67#
68for i in %{prefix}/include/python*
69do
70    py_version=`echo $i | sed "s+%{prefix}/include/python++"`
71    if test -x %{prefix}/bin/python$py_version
72    then
73        echo generating bindings for Python $py_version
74      (cd python ; make clean ; \
75         make PYTHON="%{prefix}/bin/python$py_version" \
76            PYTHON_VERSION="$py_version"; \
77%makeinstall PYTHON="%{prefix}/bin/python$py_version" \
78            PYTHON_VERSION="$py_version" \
79            prefix=$RPM_BUILD_ROOT%{prefix})
80    fi
81done
82
83%clean
84rm -fr %{buildroot}
85
86%post
87/sbin/ldconfig
88
89%postun
90/sbin/ldconfig
91
92%files
93%defattr(-, root, root)
94
95%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
96%doc doc/*.html doc/html doc/tutorial doc/*.gif
97%doc %{_mandir}/man1/xsltproc.1*
98%{_libdir}/lib*.so.*
99%{prefix}/bin/xsltproc
100
101%files devel
102%defattr(-, root, root)
103
104%doc AUTHORS ChangeLog NEWS README Copyright TODO FEATURES
105%doc doc/libxslt-api.xml
106%doc doc/libexslt-api.xml
107%doc %{_mandir}/man4/libxslt.4*
108%doc %{_mandir}/man4/libexslt.4*
109%{_libdir}/lib*.so
110%{_libdir}/*a
111%{_libdir}/*.sh
112%{prefix}/share/aclocal/libxslt.m4
113%{prefix}/include/*
114%{prefix}/bin/xslt-config
115%{_libdir}/pkgconfig/libxslt.pc
116
117%files python
118%defattr(-, root, root)
119
120%doc AUTHORS ChangeLog NEWS README Copyright FEATURES
121%{_libdir}/python*/site-packages/libxslt.py
122%{_libdir}/python*/site-packages/libxsltmod*
123%doc python/TODO
124%doc python/libxsltclass.txt
125%doc python/tests/*.py
126%doc python/tests/*.xml
127%doc python/tests/*.xsl
128
129%changelog
130* Tue Jan 14 2003 Daniel Veillard <veillard@redhat.com>
131- upstream release 1.0.24 see http://xmlsoft.org/XSLT/news.html
132
133* Wed Oct 23 2002 Daniel Veillard <veillard@redhat.com>
134- revamped the spec file, cleaned up some rpm building problems
135
136* Wed Sep  4 2002 Daniel Veillard <veillard@redhat.com>
137
138- library paths fixed for x86-64
139
140* Fri Feb  8 2002 Daniel.Veillard <veillard@redhat.com>
141
142- added the python module
143- changed the Licence to MIT
144
145* Sat Nov 10 2001 Daniel.Veillard <daniel@veillard.com>
146
147- cleaned up the specfile
148
149* Mon Jan 22 2001 Daniel.Veillard <daniel@veillard.com>
150
151- created based on libxml2 spec file
152
Note: See TracBrowser for help on using the repository browser.