Ticket #191 (new task)

Opened 15 years ago

Last modified 14 years ago

Report bug about Alpine unable to view HTML documents

Reported by: tabbott Owned by:
Priority: low Milestone: Upstream Utopia
Component: -- Keywords:
Cc: Fixed in version:
Upstream bug:

Description (last modified by jdreed) (diff)

Original report from Quentin:

My .mailcap is empty. The only thing that appears to be relevant in my
.pinerc is the line:



but /usr/bin/links works correctly, and an strace suggests that
/usr/bin/sensible-browser is what's actually being invoked.

The steps to reproduce in my account are:

  • look at a message that has an HTML attachment
  • Press . to move to the list of message parts
  • Select an HTML part
  • Press enter
  • Answer yes to "View selected Attachment?"

I get a message "VIEWER command launched", but I never actually get an
HTML viewer.

Greg Price reports that he's reproduced this and it is likely an upstream bug; we should confirm that and report it to Debian.

Change History

comment:1 Changed 15 years ago by jdreed

  • Description modified (diff)
  • Milestone set to Upstream Utopia

comment:2 Changed 14 years ago by geofft

I ran into this issue a couple days ago on Linerva. What happened was that $DISPLAY was set in my screen session to a no-longer-valid SSH-forwarded X connection, so sensible-browser was launching links -g (as reported by strace). If I ran links -g myself, I got some spew about being unable to open the framebuffer device, and an immediate quit. links by itself works, as does viewing HTML documents when $DISPLAY is unset.

There is a bug somewhere in between the path from sensible-browser to links here, in that links -g does not fall back to nongraphical mode.

Note: See TracTickets for help on using tickets.